All Nodes on top of each other

Hello Gentlemen,

Was there a solution found to this issue? I’m having the exact same problem with my nodes collapsing on top of each other and then running null even if I do un-jumble them. My coworker’s computer opened the same script I was using without issue (he does not have the same packages I have).

I uninstalled all packages for Dynamo, and sure enough, Generative Design did not uninstall, no matter now many restarts I did. I uninstalled the package through the control panel, and now Dynamo works again.

If there is a solution found to this, please let me know. For now I will use Dynamo without GD.

@ariderAEE99 Do you have any other Revit add-ins installed on the machine where you were seeing this issue?


The only add-in we use as a company is Bluebeam (and Lumion LiveSync; I’m not sure that counts).

I suspect this is not the cause, as my coworker’s computer reads the script without issue, and he has the same add-ins as I do.

Thank you,

Combination of add-ins and packages can do it. Also your Dynamo version might be different than your coworkers. Make sure everyone has all Revit/Dynamo updates installed, then check the items in your Dynamo’s notifications window (the green ! icon in your menu bar) and/or in your Dynamo log file.

Hi @ariderAEE99 - if you can reproduce this please send me (or post here) the output from this listDlls tool - it should be pointed to Revit.exe after the issue has occurred.

it will generate a list of all binaries that are currently loaded into Revit - it may give some direction.

something like

listdlls -v Revit from the command line

It happened to me when I had 2 version of Dynamo installed one older 1x and 2x version but by default opens the older version of Dynamo and nodes are on top of each other

Thanks @Michael_Kirschner2, I’m trying to recreate the problem but having poor luck. I reinstalled GD and didn’t have any issues with it. If I run into the issue again I’ll post the listDLL.

As @RubenVivancos pointed out, I noticed a version of Dynamo 0.9 was still installed on my computer, so I uninstalled that (however, this was still installed at the point of time I had resolved the node-stacking issue).

Edit: Same issue reoccurred. I’ve attached a screen capture this time. I haven’t touched Dynamo since the last time I posted, when it seemed to be working fine.

@Michael_Kirschner2 I tried to figure out the DLL software, but I know little about computer programming and I’m not entirely sure how to use the ListDLLs utility. When I open the downloaded application, a window opens with a list of all DLLs and auto-scrolls to the bottom, and then exits out without prompt.

I deleted Generative Design (once again) that I had previous reinstalled (which was working - please see my last post), and the nodes are now fixed in my Dynamo. Hope this update helps figure out the root of the issue.

Can you post your Dynamo log file from before uninstalling generative design, and the associated Revit journal?

@jacob.small Tried to attach the journals, but I’m getting a warning saying that new uses cannot attach files.

Bumped you to the next level of permission. If they don’t post now can you provide a link to a web hosting service like Google Drive, Dropbox, OneDrive, Box, WeTransfer or similar?

Sure thing!

dynamoLog_eb127b59-2c3e-4925-90aa-7d1f1f078c53.txt (58.7 KB)

Revit Journal:

Hi @ariderAEE99 - to use listdlls run it from a command prompt window

you’d run something like path\to\listdlls.exe -v Revit > path\to\someoutput\textfile.text

this will run listdlls on Revit (it needs to be running with Dynamo open and the problem reproducing) and then save the output to a text file (you could also copy paste it here) - then upload the text file here for us to see or DM it to me or Jacob.

Hello, I was working inside of Dynamo one night and this problem plagued me as well. Everything was in an orderly fashion and then I came back to open up a file with stacked nodes. I was wondering if anyone has come to the root of the problem and identified how it can be fixed. Thank you for your time!

To date, every time it has come up it has been due to a conflicting add-in or lack up update.

  1. Update Revit to the latest version that you are using.
  2. Launch Revit, open a model, launch Dynamo, open a graph, and see if the issue persists. If so, proceed to step 3. If not you’re good to go, but try to keep updates installed going forward.
  3. Close Revit, and then disable all Revit add-ins.
  4. Launch Revit, open or start a model, launch Dynamo, open a graph, see if the issue persists. If so close Revit, and provide your Revit Journal and Dynamo log in this thread. If not, proceed to step 5.
  5. Close Revit and re-initiate your Autodesk provided add-ins. Repeat step 4 and confirm the issue doesn’t persist. If the issue pops up, be sure to update the add-in. If the issue doesn’t pop up, proceed to step 6.
  6. Close Revit and re-initiate a few add-ins and re-test. Do maybe 3 or 4 at a time until the issue reproduces, keeping any offending add-in out until you have tested all passing add-ins.
  7. Update the offending add-in, or keep it off the system until a version is issued which resolved the problem.
1 Like

Hi, just had the same issue. I had Genius Loci package pending for uninstall, cause I wanted to get a newer version of it. For some reason I already had the new version, but it was still marked as pending. So I manually erased it from the local folder and installed it again and it’s now OK. Just though it might help someone

1 Like

Wanted to share my solution in case it helps anyone else.

Hi everyone! It happened to me either.

It was the conflict between Clockwork 2x(2.4.0) and Bakery(2019.5.8). I found the issue from logs first and then in the notifications.

First I removed the GD folders to my desktop from AppData and ProgramData but I did not remove the packages to figure out if there is any problem with GD. Then I ran Dynamo and still, my nodes were overlapping.

For the 2nd step, I removed Bakery(2019.5.8) from the packages and opened the graph, everything was okay without overlapping.

Then I started to reload GD files to AppData and ProgramData, then opened DYN again and my nodes still looked okay.

For the final stage, I really wanted to use Bakery so badly and I re-install another version of it to see if the last version had issues, then I downloaded Bakery version 2018.4.301.

And it worked with Clockwork and GD all together without overlapping the nodes.

I don’t really understand the problem behind this with the specific version of Bakery but it seems that different packages cause the same issue as well.

I am facing the same issue.

Here are dynamo logs and Revit journal
dynamoLog_4defddd8-40c6-444c-8382-697127918be8.txt (10.7 KB)

journal.0376.txt (148.8 KB)

With reference to image 1.png, i cannot delete generative design. How can i uninstall it.

My two cents: I’ve encountered this issue myself at least three or four times.

It is definitely a localized Issue; graphs will open up differently depending on which machine is used.

If my memory serves me correctly, this also occured on a fresh install without any packages on that machine for the new version of Revit. The graph itself likely had packaged nodes.

I think we have typicall reinstalled Dynamo to deal with the issue, but it has been a long time and the better part of my memory is exhausted.