After opening a .DYN file, software freezes, but I can still scroll through Libraby


I have updated Revit to 2018.3.2 and also downloaded the latest Dynamo version.

A colleague of mine created some dynamo files. He has left a folder with all the packages, DYF and DYN files. I have copy / pasted the DYF files and the packages in the right location.

When I open a .DYN file nothing happens, I can’t see the nodes but I can still “hover” over the library list, it’s very weird. Also when I press “NEW FILE” the library dissapears.

Here is a video of what is happening : (my software is in French, sorry about that)

Do you know where this problem comes from ? I have Windows 10 version 10.0.10240 (july 2015) and framework NET 4.6.2

Hi James, and welcome to the forum :slight_smile:

Which version of Dyanmo are you using (2.0.1 ?).

Also, have you had a look at this ?

Hello mellouze,

Yes I am using Dynamo 2.0.1.

I have tried applying the solutions in the thread you gave me (deleting the PNID folder) and now the library shows in a new document. However I still have same problem when I open a .DYN file.

If I open a .DYN file, put 1 node in it, then save it, then open it again I have the same problem. Nothing appears and there’s a soft-freeze.

UPDATE : I found a solution. The problem came from Windows Sharepoint. The .DYN files were located in C:/Users My Documents which is synchronised via Sharepoint.

When I copied the .DYN files to a local D:/Data drive suddenly everything worked.

1 Like

The old infinite loop of copying as the data is modified… ick. Good solve.

1 Like