After installing revit 2023.1, Dynamo player stopped working

When I press Dynamo player it loads for ages and after that when I hit edit input I got this message in every script, this doesn’t happen only in Synthesis toolkit but Also Dynamo default scripts

this behavior is new after 2023.1 update and doesn’t happen with 2023 version

Have you checked if the scripts will run in the dynamo that comes with Revit 2023.1?

It may give some insight to if something is missing or a error?

I uninstalled it and installed the newest version and worked perfectly, I don’t know the reason behind this behavior :melting_face:

I have the same issue still…

It happened again!! and I don’t know how to solve it
Dynamo and Dynamo player are freezing Reving when I CLICK D on Dynamo Icon and I had to force close revit!!
how could I uninstall and install Dynamo without Affecting the whole Software? older versions has this option to uninstall dynamo but in 2023 I can’t find it @tahaoglua @Brendan_Cassidy

There is no way to do this now, as Dynamo for Revit is tied to the Revit installation.

Best to identify why this is happening. Start by removing all add-ins which have been added to Revit or updated since it last worked…

This happens in the background I’m removing all add-insto check whether it will work again or not

I removed all the Add-ins !! but the problem still persists

Now try disabling all Dynamo packages as a next step.

Have you run any Autodesk software updates or installs?

I can’t open Dynamo in revit, thus I can’t unisall them
This problem happens a few times after installing revit 2023 updates! like 2023.1
The service release update causes all the problem @jacob.small

I installed Revit 2023.1 and installed clean 2023 but I faced it again!!!
What should I do, Guys

The xml settings file in your install folder should list all package locations. You can modify the folder contents by navigating to the paths contained therein, or for networked/shared locations remove the line from the xml.

You can also submit a ticket for direct support via the accounts portal at

Can someone solve it? I just updated the Revit and the dynamo don’t work. I’ve reinstalled Revit many times and still don’t work.

This is a sign of a DLL conflict, usually the result of a Revit add-in or package.

  1. Close Revit and restart your CPU.
  2. Disable all Revit add-ins
  3. Rename the DynamoSetttings.xml and packages directory found in %appdata%/dynamo/Dynamo Revit/2.xx/ where xx is the Dynamo build you’re currently using (ie: udpated Revit 2022 would be 2.16). This will prevent any customizations to your package paths and any pre-loaded packages to not load.
  4. Launch Revit, and start a blank project from no template (select none in the drop down), and set the units to imperial
  5. Launch Dynamo and open your graph.

If the issue persists check your Revit journal for add-ins which weren’t disabled (search for vendor; only Autodesk, adsk, or some variation thereof should be present). If nothing was missed post the .dyn, your dynamo log file, and your Revit journal.

If the issue doesn’t persist restart again, undo the renaming of the settings and package path (you’ll have to delete the new versions), and repeat steps 3 and 4. If the issue still doesn’t re-occur we can confirm it’s an add-in. If the issue does re-occur you can start checking your installed packages in small groups until you identify the issue.

If it’s narrowed down to an add-in, confirm you’re using the latest version of all add-ins. Then restart Revit and disable in small groups until the issue no longer persists.

I uninstalled Revit 2023.1 and installed 2023 , Revit update caused this issue to me