Adding shared Parametrs from text file to RFA



hi @Mark.Ackerley,

You always need to set the "current" shared parameter file, to be sure it uses the right one. However, you might have a point there, I could create a node there set the shared parameter file as well, and reset it back to whatever. I will look into that :slight_smile:

Therefore, DO NOT USE excel to get the parameter name, this is a bad idea.

One more thing is important, look at the input ports to see what it takes! Mine takes only one "type" at the time but gladly several parameters. I have to control every time that the proper "type" is set, but that can be added to several parameters! so hover the input ports and check what they take!
-There is several of the inputs there takes only one input and other there takes a list!

In the OOTB nodes is this not the case, but I do not understand how things like "type" can be controlled unless you send a full list of parameter, type for type so to speak.
-List level will only work if the input has the same length!

So the backside is clearly that you need to understand the nature of what the node takes for input, and that goes essentially for all nodes throughout dynamo.


all you need to do in the first place is open a family, and get the “green” box working… then add the “red” boxex when it works… thats it :slight_smile:

And as @Mark.Ackerley points out… you need to set the “shared parameter file” INSIDE REVIT to be the COBie one… Do not use Excel …you can reset your SP file when you have done whatever you need to do with the COBie stuff.


Yes agreed :smiley:

But if you have a few thousand families that you want to add a few thousand parameters too, you might want to speed that up a bit…

I’m getting the same results if I put everything in twice…


then you do it like this…

one “green” box for each type, you can add all the parameters using this one type at the time… no problem :slight_smile:


Unfortunately that’s not working for me…

Add Share Parameter to RFA-MKAByType.dyn (116.3 KB)

EDIT: Images don’t expand when clicked on, when did that happen?!


please get rid of the excel part. You can set a SP file inside Revit, and reset it afterwards…


Ok ok…

I get a different error now :slight_smile:

Add Share Parameter to RFA-NoExcel.dyn (100.3 KB)




I have created a beta build (BETA_6927) could you please test this version? Hopefully this has fixed your error…

I have also created a new node for setting the Shared Parameter file. The idea is to set the "new" SP file, then do your stuff, and in the end, return to the original SP file. If you want to test it without any "Stuff", then use the Circut node, set it to false and then you can verify that the SP file changes. then test it with the Circuit set to true and you should end up with the file you had in your file (must be reset between the two tests).

When you want it included in a graph, then use the Await node, waiting for the "Stuff" to complete before setting the original SP file back again.

SetSPfile.dyn (8.7 KB)


It’s awesome that you’ve got back to me that quick :slight_smile:

I have updated and tried to utilise the new nodes, unfortunately I am now getting a slightly different error?

I tried using end-start transaction nodes but it didn’t help :frowning:

Add Share Parameter to RFA-NoExcel.dyn (109.5 KB)


dont overthink things :slight_smile:
…yes this will fail… you should only set the file once!

In the Python script node you open the SP file, this might be a problem!

try this
Add Share Parameter to RFA-NoExcel.dyn (83.8 KB)


Yes I had the same issue I had zoom into my screen to see the whole thing


I had to use get item at index, as there are levels…

But still the same error… :frowning:

I tried dispose? Perhaps that’s wrong… it didn’t seem to help… :frowning:


Add Share Parameter to RFA-NoExcel-2.dyn (88.0 KB)


ahh… yes of course… the group name is the wrong one every time!

new nodes need to be coded… I will look into this


here you are… another new node (Parameter.GetSharedParameter) …get the updated beta build, and please let me know if this works as expected now :slight_smile:

Add Share Parameter to RFA-NoExcel.dyn (48.1 KB)

Create Project Parameter from Shared Parameter

Woop Woop! Amazing work :slight_smile:

Thanks Erik, if we don’t speak before, have a great Christmas!

My slightly tweaked version…

Add Share Parameter to RFA-NoExcel (3).dyn (52.2 KB)


@Mark.Ackerley, you are welcome… I will try to see if I can do some improvements on the nodes before “release”.

@s.rooble, could you use some of it? did this solve your issue as well?

…and may you all have a great Christmas :slight_smile:


Dear Both @erfajo @Mark.Ackerley I want to thank you for solving the issue I will try this when I jump back it and give it a try


I have now finilized the nodes… they ended a bit different than the beta builds. First they got their own “class” named “SharedParameter” and I ended creating all in all three nodes. In the last run I ended creating two “query” nodes getting all the parameters in the SP file and group them either by type or by group name.

Therefore does the updated graph look like this…

Add Share Parameter to RFA.dyn (52.5 KB)

Orchid update feed

I Can now thank you so much after the migration and dealing with the previous issues I am now able to add shared parameters to the families however I can not get the type parameters on there for some reason


please start a new topic and refer to this one for historic links.
Next… always include image of your graph and the graph file…