Achi-lab version problem

Hi all,

I got a problem. see picture below. this is my current version of dynamo in revit 2022.
Dynamo version

for archi-lab it looks like i need a higher version, but it says up to date.

How can i solve this problem?

thanks in advance

Hi @1234eddie ,

The “Up-to-date” means that your Dynamo version is up-to-date for your corresponding host version, this has nothing to do with your Custom Package versions.

For the Archilab version you have to match the version of Archilab to the version of Revit which you have. I.e. Revit 2022.x → Archilab 2022.x, please search the forum for this.

1 Like
2 Likes

Dear @JacobSmall

thanks for your reply. i now understand what it means.

but this is what i get when i try to install the version for Dynamo 2.10-revit 2022

install error

can you or @Konrad_K_Sobon tell or investigate what could be the problem?

Have you uninstalled the previous Archi-lab package you had on there before? You will need to restart Revit between the uninstall and install.

Thanks @JacobSmall

that solved my problem for now.
but it will be quite annoying for our company, because some project(client related) are in revit 2021, others in revit 2022.

is my conclusion correct that i have to uninstal and instal everytime i switch from revit versions?

Thanks in advance

Gr edward

AFAIK Each Revit version runs a seperate / different Dynamo version, so no.

That is also why there are multiple versions of some packages (one for each Revit version. Often only the latest three releases are suported).

Also see this topic.

Also note that changes made in a Dynamo version (i.e. path settings) they aren’t ‘carried over’ to Dynamo for a different Revit version.

Personally I save my custom packages in different folders (one folder for each Revit version).

Some one correct me if i am wrong :stuck_out_tongue_winking_eye:.

Starting with Revit 2022 if not 2021, it’s basically impossible to have a single package set for multiple versions. There are simply too many software updates to hope that a single package would successfully cover all the bases. My recommendation is having a deployment to the local systems for each build in use, for both packages and graphs run via Dynamo player.

@JacobSmall @Konrad_K_Sobon
due to some projects we need to use RVT2020. revit 2020 has dynamo 2.3.0
Our question is which version of archilab do we need for revit 2020.

Thanks in advance

Per the autolinking Archi-lab post here, the most recent version which ends in 20.