Workspace Cannot Be Exported As An Image

I almost always export an image of the workspace of my “final” graphs, so that I know what I had when a working version was created. I love the image export feature, but in 2.19.3 (Dynamo Core 2.19.3.6394 / Dynamo Revit 2.19.3.10292) running from Revit 2024.2 (24.2.0.63; 20231029_1515(x64); 2024.2.0), I keep getting an error message that I have never run into in previous versions:

The workspace cannot be exported as an image because it contains nodes that are too far away from each other.

image

This is happening in graphs that had no issue being exported in previous versions. I know the nodes are bigger now, but the size of the graph has not changed that much. I just tried the image export on a three-node graph. You cannot get much smaller than that, and I got the same error. Is this just a problem with the image generator in general? I searched, and I did not find any other threads on this topic. Am I the only person who uses this feature? Or is there some setting that I have overlooked?

Here is the three-node graph that failed:

David

Hey @David_Koch - long time no see!

I can’t reproduce the issue on my end - can you post the actual .dyn? It may be that over time your graphs have shifted to be REALLY FAR from the origin. This is something I can quickly check, but not without the file itself.

Thanks!

Thanks for the response. Its been quiet in the Community Conversations - sorry, Events - area lately.

The three-node graph was started from scratch. I would hope that would be near the origin. I did not save that one. The attached is the one I was trying to capture today. In looking at the files I have, I was successful in getting a screen capture of this graph on January 2, 2024, but not today.
2-19-3_EC Revit 2024 Worksets.dyn (53.0 KB)

1 Like

Revisiting this, as I continue to have this problem in Revit 2024/Dynamo 2.19.3. To test, I started a brand new graph and put some test nodes on the screen without panning or zooming. I get the same results - the nodes are “too far away from each other.” If they are far from some unmarked origin, that is because Dynamo is opening a new graph far from the origin.

I have attached the DYN file as well.
2-19-3_TestGraphForImageExport.dyn (6.6 KB)

1 Like

Hey - sorry for not following up.

I wasn’t able to reproduce so it might be something in the system. Can you try from a Dynamo sandbox insurance? If that doesn’t work can you post the journal for Revit and the log from when the export failed?

FYI @Michael_Kirschner2

so the error is also shown if the image fails to be created for lots of reasons… :man_facepalming: - so also make sure that Dynamo has access to this path (the user you are running Dynamo as)

1 Like