Wall Opening Family doesn´t make a hole

Good evening Dynamo Community!

I am placing wall opening families by ducts from a linked file.
They are placed in the right spot but they only show as rectangles in Revit.

If i make any manipulation in revit, for example changing size or level the hole instantly is there.

I´m pretty confused because it already worked a few times, some times by running the script again. I already tried new transactions…but i really can´t get this to work. Also changing parameters like size or level with dynamo doesn´t help :confused:

Would be really happy about any advice! :slight_smile:


How about a hack? Does ‘End Transaction’ then SetParameter Offset +10 followed by SetParameter Offset -10 work?

Good luck,


1 Like

Thanks for your reply Mark, i already tried that but it doesn´t work.
I thought the problem could be the host, but it finds the wall as host…

I added a bunch of transactions and found the “solution”, so you were right mark!
I have to set one parameter a second time to make it work. Until now i always tried to set the same value twice, but it only works if i set 2 different values.

Would be interesting why this happens…but i´m good if it works

1 Like