Void family doesnt work with dynamo

This script now seems to work when I run it 2 times. I cant figure out why it does this?
Attached is the dynamo scripttest1.dyn (75.3 KB). What am I doing wrong?

Im trying to place familys on a surface by adding points. This works. Then I want to cut the family using a void family around the edge of the surface. This worked in dynamo in a test version using the same nodes I used on the attached script. Also when I manualy cut the familys in Revit with the placed void family it works fine. But somehow it is not working in an automated way via Dynamo? Attached is the dynamo script and a printscreen of the output in the model. Can anyone see what Im missing?
(Just to be clear, a part of the script I uploaded is not generating anything and is freezed. The part with notifications is needed for when there is a void in a surface. In this case Im using a surface without a void, so this part of the script is giving an error but that shouldn`t be a problem).

test1.dyn (75.3 KB)