View Type node giving multiple viewtypes ffor schedule viewType

i delete and undelete the node and the full script runs fine.The duplicates start appearing only when i run script again .

Hi @maheshnaik.mumbai

Can you please provide more information. An image of your graph, what version of Dynamo/revit, if this is an OOTB node or from a custom package etc. It’s easier to get help if you give us more to work with.


i have attached the png which i got from the net…I have just started with dynamo and no only how to fire up Revit…I am just processing schedule outputs.

And here is the png of the screen after 1 run.I had change some node parameter names to xxx,zz(that works nicely);I want to avoid any python.

Hi @maheshnaik.mumbai,

I’m not sure where you are having a problem. I have recreated the script and seems to work fine…

One difference is that i have a boolean toggle controlling a refresh on the View.GetBytype allowing a full refresh of the data. Not sure if this is the problem you are having but worth adding to your graph.


I will try and post.My puzzle was that after 1 run View type gets a additional viewtype on the output side and the connector shifts down.I had a working patch …I used to just remove view type and undelete again .The run would go thru right for the next run .

Oh…I see! Hmm! That is weird! Can’t believe I didn’t see that! I was thinking the data was being duplicated after your first run.

This is more of a question for the Developer of the node. I’m assuming it’s archilab (as that’s the package i used)? Make sure you have the latest version installed as this may be fixed. Also, what version of Dynamo are you using? 1.3.3 or 2.0.1?


i am using 2.0.1 of dynamo.I am not sure of I will update the archilab node as you suggested.6-5-2018%2012-40-00%20PM

Which package does the node you’re using come from? This behaviour should not happen. Perhaps @Michael_Kirschner2 or @Kulkul can advise as I’ve not seen this before.

I tried …the latest package .The site says it is for dynamo 1.3 ?

Archi-Lab worked for me with no issues so perhaps use the nodes from that package. From reading the history of the Archi-Lab updates, it sound like there has been work done to make it compatible with 2.0. But to what extent, I’m not sure…


I have attached a png here. the 2 node dynamo runs first.But if i save it and read it agin ,the view tyope has a additional output node .A output port is born everytime I save and recall.If i delete the node and run it runs properly.

Why is this happening.?.
I am new to dynamo …nil in revit…

tq.dyn (5.9 KB)

Hi @maheshnaik.mumbai,

I am not getting the same error. Initally when opening there were 2 ports, i deleted and undid that and that made sure only one port was showing. i ran multiple time and no other ports were added.

I think this is most likely to do with your install of the application. I would uninstall Dynamo fully and reinstall a clean version.

Before you do, are you getting the same issue on all nodes or just this one? Also, are you getting the same problem with simlar dropdown nodes like the Categories node in Revit.Selection library?


Good evening(IST)

can you please provide me a 2 node dynamo script to try…to what node do i feed the output from categories?

Hi @maheshnaik.mumbai,

Try this and see if you are getting the same issue for both drop down nodes…

Test.dyn (5.5 KB)

this 2 element great script has no problems.
I will reinstall dynamo as you suggested.Till then i will entertainmyself with some other algorithms.

Thank you for the sample.
When i opened in it dynamo i got 2 viewtype output ports. On running i got the attached colours.The categories node had no problems.

when i move th connector up andrun then run i get this.