View.SetCategoryVisibility List Lacing

Hello all.

How can I get the Lacing to work with the View.SetCategoryVisibility node from MEPover. I have tried nearly every combination of levels and list structures (I did not say every combination because I have not figured it out yet but it sure feel like I have tried them all).

I did a search and found this but it is not helping.

Any advice?

Thank you for your time,

Hi, are you sure the node is from Clockwork? I cannot find it anywhere

That is my bad it is from MEPover. Not sure where I got clockwork. Sorry about that.

If you want to hide those categories (in your case, those lines) in those views, I would simply use one False, with Cross Product lacing.

Otherwise I would split your categories in two, one list for false (to be hidden), one list for true (to be visible).

Hope to be helpful :wink:

1 Like

That would work. Does it take longer to do it this way though? It will turn off the the first line complete task and then the second line and complete task rather than turning them both off at one time and then completing the task? I could be 100% wrong on this.

I’m not sure to understand. Do you mean if it takes more time to process if you have many views and categories? Anyway I don’t see any other way, maybe recoding the python script in the node, but I don’t see the point :slight_smile:

I am running it on every view / view temple and maybe more than one category so it could take a little bit longer. I will just run it as cross product though for now. Thanks @iucamanzoni

You need to hide X categories in every Y views, I don’t see any other way than a Cartesian Product. It’s gonna be anyway faster than doing it manually in Revit.
If you are satisfied, please mark the topic as solved :slight_smile:

1 Like

Very very true Thank for you help