Update Family Fonts in a directory

Hey Guys,

I’m struggling trying to update all the fonts of the labels of all families in a directory. I’m using the Rhythm nodes, but I’m having no luck.

Below is what I have

Any suggestions on how I can get around the error of “Trying to edit a model outside of a transaction”? I’ve tried manually creating a transaction which doesn’t work either. It works fine on TextNoteTypes, just not TextElementTypes. I haven’t tried filtering just to include Labels, but I don’t mind if it updates both.

Hey there Chris!

This is going to prove a bit difficult with Dynamo because it is primarily designed to work on the current document.

You might be able to get this to work if you were to get a node setup that takes a document as an input for setting the parameter in that document.

I would suggest taking a look at RevitBatchProcessor and build the graph in a “current document” way to use across files:

Another option that I have used before is DynamoAutomation:

1 Like

Hey John,

Thanks for getting back to me.

Oh well. I tried that, but it seems to open a new session of Revit for each item, so the time it takes to Open/Close Revit 2020 pretty much the negates the process of doing it manually (and won’t give me the option of using the same session - greyed out). Doing it manually at least I can resolve any issues as I find them.

If my dev’s weren’t so busy on other things I’d get them to do me a quick app to do it…

Also, I think the orchid package does some of this because he built out more background document nodes than I did. I saw how unstable dynamo can be with background documents and strayed on the side of caution. (Not saying that it’s undoable or anything)


Side note. I might have to talk to Aaron about our internal solution and see what our ongoing confidence is in it…

I do think CTC’s batch processor can do it too.