Unit mismatch when using Rhynamo

rhynamo

#1

 

 

 

I’m using rhynamo for for the first time and I ran into a little snag I was wondering if anyone had run across before and found a solution for: the rhino file, Revit project and family are all in meters, but when I bring the geometry in through rhynamo it is smaller (possibly in inches?). you can see it in the provided screen shot, the cube shows the Revit origin, the large manual import on the right was brought in as SATs and the rhynamo import is in between. Anyone found a solution for this before?

units mismatch using rhynamo


#2

This all depends on what version of Dynamo you are in. Latest 0.8.0 is unitless which means that when you interact with Revit every unit item in Dynamo is equal to whatever units you have in Revit. To get the units right just make sure that your Rhino file is in the same units as your Revit file and conversion should be seamless.
Previous versions of Dynamo 0.7.5 were not unitless and they were always working in Meters under the hood which might be causing a lot of confusion when importing stuff from Rhino.

This brings me to maybe suggesting that you use Mantis Shrimp instead. If you are in Dynamo 0.7.5 then download older MS as well and Units are being handled by MS under the hood. If you are in Dynamo 0.8.0 then download latest MS and just follow my tip from earlier about matching units in both software packages.

Good luck!


#3

Nice! Thank you! That worked as soon as I switched to 0.8. And thanks for the tip about mantis shrimp. I saw it before, but I’ll give it a second look.

Thanks again.


#4

Did you have to scale the Rhino model by some factor to get this to work? I’m having the same issue and changing the units to Feet / inches in the Rhino model to conform with the revit model doesn’t seem to work simply from the unit options. I was hoping I wouldn’t have to lose the measurements in Rhino in order coordinate once rhynamo spits things out in revit. Thanks,


#5

So I tested this with MS and Rhynamo, and the Rhino model has to be scaled in order for either package to read the correct units in Dynamo 0.8. Not sure how this was resolved in the previous cases then. Let me know if there is something else that was done to overcome this issue. Thanks.