Trouble with planes

Hey everyone,

I am having a difficult time understanding planes in Dynamo and was wondering if anyone can help me. I am not sure if this is a family problem or if I’m doing something wrong so I would like some insight.
Here is my situation. I want to add a target in the middle and I managed to do that.
The problem that I am getting is when I try to place that target somewhere else.

.

I know that I can rotate the family but then I get an error when I try to do that.Revit_NW06fxEKDZ

I can manually add the target in the middle but then I would have to do something like this.

I think this has to do with planes and Dynamo not recognizing what plane to place the family on. However, I did create a plane in Dynamo but the family is still not being put there.

I am not sure what I am doing wrong and I would appreciate it if someone helped me.
Here is my Revit file and graph.


Middle2.rvt (1.7 MB)
Target in Middle.dyn (57.2 KB)

This isn’t an issue with planes so much as t is with the hosting of the element. The FamilyInstance.ByPoint node doesn’t allow for elements to have an altered Z state, so you either have to use a method like FamilyInstance.ByFace or apply a transform after placing the family.

The manual method you show appears to be closer to the FamilyInstance.ByFace method but I’m not quite sure.

1 Like

Hey Jacob,

I took the advice you said by trying out familyinstance.byface but I keep getting an error and everything seems correct to me so not sure what is going on.

I also tried using springs familyinstance.byfaceandpoint but that one gives me a null result and again I am clueless on why that is.

I also tried the transform node and it works just fine. However, when I transform it, the location it is placed at is off so I will have to do some tinkering to get it to the right location. Futhermore, the transform node only accepts geometry and not a family instance. So once I find the proper location I need to turn it back into a family instance and I have no idea how to do that. Maybe I am overthinking this but here is what I got so far.

EDIT:
I actually ended up figuring out why byface node was not working. I just had to add 2 more extra nodes and it worked as intended.

I would still like an explanation on the whole transform node though. Maybe i’m just using it wrong or something. How would I transform a family instance and then put back that family instance once it is rotated? May I get an example of this if its too much to ask?