Tools for Doors/Windows in a room


As I said on this topic, Use Room.Windows node

I try to link the rooms of my project with their doors (or windows wich will be the next step).

For that I used two solutions :

First solution : Tool.GetsurroundingElements (steamNodes Package)

The problem is : This tool link each rooms with their doors, but also the other doors close to this rooms

For exemple : The Room 643039 has just one door wich is BPCV_2V_140x200h, the others doors are doors close to the room 643039. I tried to decrease the Tolerance, it’s better, but still not correct

Second Solution : Room.Doors / Room.Windows (Clockwork Package)

With this solution, I can find the rooms and the phases, but I can’t link the rooms with the doors/windows and I don’t know why…

Also it is possible to use more than one phase ? (I have 3 on my project)

Thank for your help.

For option-2: First confirm which phase your using and add “Element.Name” node to list of phase and take proper phase from list.

1 Like

I’m using phase “projet”, but it can’t find something with this phase or another (I tried it with all my phases)

1 Like

Which Revit and Dynamo version your using?

Try this:

1 Like

For this project I have to use Revit 2015.

I can use 2016 or 2017 but I will not be able to share it with my partner (but if it’s necessary we will find a solution)

Dynamo 0.9.1 for this exemple

I can use also 1.0.0 (but it will be translated in French)

OK thx I try it

(With Dynamo 1.0.0)

—> I’m lost :slight_smile:

Sorry your using french language it seems.

Hahaha Yes I had to change Dynamo 0.9.1 for 1.0.0 to use the package and Dynamo 1.0.0 turn it in french…that’s why I noted it

Can you install Revit English version and try.
Or else modify the Python Script try changing “Phase” to “Portes”.

Thank you very much Kulkul, now the script is working, but I don’t understand the error with the “Element in Room” node

I think its because of your Revit French language.

Actually on the last screenshot I used Revit 2016 which is in english and Dynamo 1.0.0

As you can see, I use Rooms and Doors categories instead of “Pièces” and “Portes”

Ok so it’s working with the category “windows”.

Don’t use “Element in room” node. Use the other room.doors and from clockwork package. My previous example of “Elements in Room” is for only Doors facing inside room.

You can also use “Rooms.InsertsofBoundaries” node from clockwork package to get doors from rooms.

1 Like

I don’t really understand why it’s not working on my project…

But I thought about another solution

Get the all room’s walls, with the Tool.getsurroundingElements node and check if in each wall there are doors or windows…

I don’t know if it’s possible, I will try it today

Ok so same problem – > My Room 640953 don’t have 42 walls…but just 8


I found a solution to link the doors with their rooms with the “Get To-From Room” node (BIM4Struc package).

Actually it’s not perfect because at first I wanted to link my rooms with doors (on the contrary to link the doors with my rooms…) but it’s ok.

For the windows this node is not working…

Actually the Room 1279212 don’t have any windows and even less a window shared with the Room 1222835…

So I had to find a solution without using this type of node, because (I don’t know why) when I have to use the “phases” of my project… it’s not working…

I wanted to split up the node “Room.Doors” (clockwork package) to understand why the phases parameter of my project don’t work…

this node use “Door.Rooms” which is using the phases too… so I changed it a little bit firstly to not using the phases and secondly to adapt it to the windows

and it’s working ! BUT the windows’ list don’t match with the rooms’ list…

I should have to change the code block but I can’t make it easily…

So If someone has a solution to change the code Block or to explain me why the “Phases parameters” don’t work on my project it will be very very cool.

By the way, the Phases parameters works on another project…