The parameter's storage type is not a string


I am really new to Dynamo and I am trying to copy some values from one parameter (COBie.Component.Area (BIM 360)) to another (COBie.Component.Area) . However when I press run and it comes with this message “The parameter’s storage type is not a string”. Any help please ?

use a String.ToNumber from your GetParameter node to the SetParameter node. The Cobie.Component.Area is looking for a Number it sounds like and not a “string” or text value, which is what the GetParameter node must be pulling.

Sean Thanks for getting back on this. Apologies I am new to Dynamo and I am not really getting where should I input the string to number. Could elaborate a bit more please ? Thank you !

Try this.

1 Like

Thanks Sean it worked for the COBie.Areas but not for the length for some reason.


1 Like

You haven’t connected the value to the SetParameter Node.

When I do that it comes with the same error as before. “The parameter’s storage type is not a string”

Try this


The parameter needs to match or you need to convert the data type to receiving parameter.

1 Like

Ha, simultaneous posting! This is why it is best to only have one post.

1 Like