Surface.Point.At.Parameter not aligning with XY object from Revit


#1

Hi,

See screenshots and files below. When a Face, coming from an Floor object in Revit, which is not aligned with the main WCS X-axis, is connected to the Surface.PointAtParameter node, then the points are generated according to the global Dynamo X-axis and on the XY boundary box of the face. When the same script is done on a Face selection of a wall, which is also not aligned with the X-axis, then the points are nicely generated within the curves of the vertical face.

Anyone an id ea how the generate the points on the XY surface so it follows the red arrows indicated in the picture below?

Thx.

These are the datasets:

Revit: Surface point at param
Dynamo: Surface point at param

Wall

 

 


#2

I can replicate this on the 0.82 stable build.

2015-10-07_21-36-28

I thought we could easily circumvent this, but I was wrong. First I tried rotating the face till it’s aligned with the global axis, and then rotating the resulting points back. This failed because the surface kept its original orientation.

2015-10-07_21-52-35

Then I tried to transform the surface to the identity CS, but that failed as well:

2015-10-07_21-48-54

I tried a vertical transformation but got the same result:

2015-10-07_21-55-05

Extracting the element solid and deriving the surface from it, produces an identical outcome.

To me, this looks like a critical bug. I strongly encourage you to report this issue on github. The only other workaround that comes to mind, is to translate the perimeter curves (or divide them and connect the points) and intersect the resulting curves.

2015-10-07_22-14-06


#3

Logged in Github as https://github.com/DynamoDS/Dynamo/issues/5475

Thanks for the workaround Dimitar.