Surface Area


I am trying to extract the surface area of Adaptive Components I have placed in my model. I seem to be getting mixed results with the area output.

These are the components I have placed you can see they are roughly 15 square feet, but in Dynamo they are only around 1 sf. My area units are set to display at SF, what am I doing wrong?



Dynamo Snag 2

Dynamo Snag 3

Unfortunately, Dynamo is not clear about this at all right now. Those numbers are actually in square meters. Everything in Dynamo is in SI units unless otherwise specified. And by “otherwise specified,” I mean that the unit would be displayed along side, like “12 sq ft”.

The units display setting in Dynamo affects numbers that have units associated, and this mostly happens when quantities come from Revit directly. However, the Surface.Area node is from the geometry library, and it doesn’t know anything about Revit. It returns only a number, not a number with a unit, so the number is as if it were in SI units. You could see a difference more directly by comparing numbers that have units with those that don’t.


It’s on the development track next year to clear up this confusion. We have some ideas, but how would you like Dynamo to treat numbers vs. numbers with units?

Thanks Colin!

This explanation is very helpful. thankfully Andreas has created a custom node for converting units!

Hi Colin,

I have run into the same issue when trying to work back from Revit to Dynamo and then back into Revit with units. I have been using adaptive components that reference the Level Elevations to create a top point that is always ‘hosted’ to the ceiling using a plane offset node and then building geometry off of that. Being able to adjust the levels in Revit like I am familiar with and having it drive a response in Dynamo is ideal for the hybrid workflow.

My suggestion would be to have Dynamo reference the Revit Units to determine which units are being used. Maybe since Dynamo is looking at being more independent, it would make sense to have a ‘sync units’ option to look at the program that it is currently plugged into and match the unit type. If nothing else, it would be great to be able to change the units already in Dynamo under ‘Settings’ and have the units translate to all the numbers in the definition. I understand that some numbers need to only be a factor and not unit-specific so maybe having a toggle directly on the node (much like the built-in watch node) could transform an arbitrary node number to something unit-specific. This toggle option would only be available on nodes generating numbers.

Food for thought. In the mean time I guess I’ll just have to get my conversion on. Glad to see this issue is being addressed and keep up the great work!

Tim Capture-Dynamo Units Issue