StructuralFraming.BeamByCurve not respecting the curve


#1

Hi !

I’m facing a problem I can’t understand so I need your help…
In my Revit model, I’m selecting a floor, then I create curves on the upper plane of this floor and finaly I place beams along those curves with the “StructuralFraming.BeamByCurve” node.
The first image shows it, I get the right curves (in blue) but my beams are sometimes longer or smaller… I also tried with other beams and the result is the same so the problem isn’t the beam type. It seems like it automatically adapt the beams’ length when there is another wall below.

Does someone have a solution for this problem ?

Thanks a lot !

Anne-Sophie



#2

Hi,
That’s just standard Revit behavior… If the beam family is set to concrete and both it and the wall below it share a material, the two will automatically try to join each other. Seems like you’re using precast beams. Is your beam family set to the correct Precast usage?


#3

Thank you for the answer !
Even if a place metallic beam the result is the same, is that normal ? Is it possible to avoid them to join each other ?


#4

As I said earlier, all you need to do is change your family’s material setting. Here’s the exact same beam family loaded twice. the top one is set to concrete and the bottom one is set to precast. They’re set to be flush with the wall’s face but as you can see, the concrete one is getting extended and joined:

The setting you need to change is found here:


#5

It finally works :slight_smile: Thank you for your time !