Sort by Family Name - Not by Family Type


#1

Hi,

Can anybody tell me how to sort by Family Name and not Family Type? I have made this Dynamo script which is working great, but I have 4 different Types in one family, and I want the script to run on all of the types - not just the one of them.


#2

You can use All Families of Category from Clockwork to get a list of families, then select the specific family by matching the name.


#3

Hi @mee

Another possible way…


#4

@Nick_Boyts Thanks - I’m new to Dynamo, so can you explain in more details how to use this?
I’m not sure how to continue from here

@Kulkul Does you solution only work for active views?
I have tried yours as well, but I’m not sure how to connect it to my string to make it work correctly.


#5

@mee No! It works for all the views you just have to connect your list of elements to “GroupByFunction” node and func as “Family.Name” node. Does that make sense?


#6

Hmmm, I must be doing something wrong here. I don’t get the correct result from the parameter as I did before:


#7

You need to search your list of families for the one(s) you need. Then you can get a list of the types contained within that family.


#8

@Nick_Boyts

Thank you so much! I can now sort by families, but the rest of my string is not working anymore. It looks like it can’t find the parameters a, b,c and d, which was no problem before.

What am I missing?


#9

If those are instance parameters you’ll have to use All Elements of Family Type to get the family instances.


#10

@Nick_Boyts - It is instance parameters. Can you show me how? No matter what I try it won’t work.


#11

@Kulkul Can you help?


#12

@mee Sure! Could you drop the relevant rvt file in one of the dropbox services and share the link here.


#13

@Kulkul Thanks! It’s much appreciated :slight_smile:

You can find my test project and my dynamo file here:


#14

@mee Here you go try this dyn file LDR_Lindab-kode_test2(K).dyn (20.4 KB)


#15

@Kulkul
Thank you very much. It works!
So I had to keep both “Family.Types” and “All Elements of Family Type”. I tried both of them - but not together. All beginning is diffucult :slight_smile:


#16

@mee could you mark the post as solved. You’re Welcome!