Sketchup Dynamo anyone?


#1

Hi everyone,

I just tried this workflow http://www.martinportfolio.com/blog/2016/3/22/sketchup-to-revit-with-dynamo

but I couldn’t reach the last step (exporting it as a family)… Any ideas on that? Anyone has succeed in using
this definition?

Thanks


#2

Can you post an image of where it falls apart for you?


#3

you see, the geometry is currently loading in Dynamo, and I don;t have any error… Basically I don’t have the family istance in the project… It won’t appear… (but the 3d blueprint lines from Dynamo did appear in the 3D view)
Is it because of the family template, some nodes, or what?
(I tried even to get the model from the mesh node, but Dynamo crashes everytime)…

Thanks again


#4

Can you check if your Geometry.Translate node is actually passing Geometry since it’s not fully connected (just give is a 0 value otherwise).

Are you still using 2013 Revit Family Templates?


#5

It worked, kinda of…

It actually exported some geometry… Why it the other one not been shown? I mean, there are like 11 surfaces in the node… and in the node preview the geometry appears properly… so what’s wrong now?


#6

Check if you are actually passing the Geometry to the FamilyInstance Node. Since it’s working it gets all the needed minimal input. First thing to check would be if you are actually succeeding in extracting the Solids from the surfaces of the Sketchup model. Turn of all the previews of all the nodes before the Geometry.Translate Node. The preview you are seeing is the Dynamo representation of your skp surfaces, that does not have to mean it is a Solid.

If you start troubleshooting this kind of stuf here, please take a look at this: How to get help on the Dynamo forums


#7

Bjorn sorry to bother you, I read the instructions, I didn’t mean to be lazy, it’s simply since I’m a beginner use of Dynamo sometimes I don’t get the logic of some definitions, especially when they don’t actually give any problem in Dynamo. That’s why I’m asking for help.

Seems to me like the geometry has been exported, or not? This is the representation of Geometry.Translate…


#8

The preview shows null. Try skipping that (wire from the solid to the family instance node) instead


#9

Nope, I get the same geometry… maybe it’s something in the polysurface.byjoinedsurfaces, or in the Sketchup.LoadModel node … I tried with different sketchup files, even a cube gives me error…

I don’t have any other clues… And from the blog I viewed seemed like a stupid thing to do, uh! :frowning:


#10

Shows as null in the preview. Something is off with that translate node.


#11

Yes, I tried to get directly to Springs, but it gives me “null” anyway…