Shared parameters - adding

Hi.
I created script to adding shared parameters using .txt file - in the same way how it was described in data-shapes page:

I choose category and parameters to add.
Always after run, I get message about added parameters (“X shared parameters addes to project”) - but in chosen categories nothing appear.

Have someone similar problem?

Does your graph show an error? If not, please post a picture of your graph with the data bubbles unfolded so the community can see what’s going on. :slightly_smiling_face:

Graph doesn’t show errors. You can see my scirpt below.


I am attaching gif where I couldn’t added parameter to structural framing. In previous step I added them into Structural column - in the same way.

is that you are intending…

31.Shared parameter add using text file to project.dyn (11.0 KB)

Yes, I did it the same way but using ‘data shapes’ nodes.

I tried a lot of experiments and I noticed that all work fine when I use .txt file which wasn’t use before in that model. When I run the script I’ve got all shared parameters in “Shared Parameters” manage and then I cannot assign them to new categories using Dynamo (despite I get a comment that all parameters have been added). But when I change .txt file to another - all work well.

To sum up, I can use that script only once - later I cannot assign parameters to other families.