Setting multiple Family-types parameters at once

Hey Guys, having a bit of trouble here, hoping some one could help a bit :slight_smile:

Im trying to get a parameter from all elements of a type. That i did, then i add som “.” in the parameter and need to rewrite the new values in to another parameter.

This is what i came up with so far. But something aint right where i wanna put the values in again… Anyone got any ideas? Or am i all wrong on this workflow?

And the graph ofc. :slight_smile:

Code translating v 1.3.dyn (8.5 KB)

Do this changes in your graph.


1 Like

Hi guys, I am having some trouble getting a script to work. I am a newb to this stuff so please be gentle. Its similar to the thread title, I am looking to create a type list based off of an excel spreadsheet. We often use multiple iterations of the same type in any given family. Where I seem to be getting hung up is when I go to convert my string into duplicate types. My list is showing null though I have already removed nulls in a prior step. I can only assume I am missing something. If I change the source to a simple code block it will add a single type as I am looking for but I have not yet figured out how to pull a list of multiple types from excel and have them created.


@DJ_949 It looks like you need to remove the “;” from your strings.

In Revit, Family Types or any elements (families, views, sheets) can’t have that character in their name. If you tried to create it in Revit you’d get the warning “Name cannot contain any of the following characters: \ : { } [ ] | ; < > ? ` ~ or any of the non-printable characters.”

Thank you for your help. I went back and gave that a try with no luck. It’s only creating the first value I have listed in the file “_54 2”. I was under the impression the “;” was needed for differentiating each type that I wanted created. Perhaps that came from a different approach as I have tried using a list for this as well but later decided excel would be more ideal.

@DJ_949 Can you upload your .dyn and Excel file? Its hard to discern the problem from that screenshot alone

I would also try flattening your list of names.

You should be able to point it at any family in your project and have it create a new list of types based from the excel. Thats the idea

That’s what I was originally thinking was the issue but no luck.

What package is that node from? Have you tried using the Springs node?

The .xls file link is saying I need permission.

D’oh. Not sure why I didn’t think of this first because I just answered this the other day:

Maybe its reading “null” because you’ve already run the code so that first family type has already been created.

Sorry about that I changed the permission.

Thanks again for all your help. I’ll try this latest recommendation and report back.

I just tried with your .xls file and works on my end when setting Lacing to Longest. :slight_smile:

Can you show me a screen shot (Rookie here)

You can read about Lacing here:

1 Like

It worked. Your my hero! Thank you!

You’re welcome :slight_smile: