Change multiple types with Excel


  • I’m trying to export elements (loabable&Sytem) from Revit to Excel with RevitID. That’s working already!

  • In Excel I change the Type to another Type that exist in my project. Fine!

  • Then the way from Excel to Revit, I can filter all the elements by Element ID. And I get the right value(Type) from my Excel.

  • But when I want to set the Family and Type to another value with “Element.SetParameterByName” I got an error. Is this because the Type name of an element is not a parameter? Somebody have a solution to change my type?

Thanks anyway

I think you have to change the type!

Tried it also with Type, got the same error. Its not rename the type or duplicate it. I want to change my Type to an existing one in my current project. But I want to change it in Excel.


Use element set name

My elements doesn’t change? Get no error but nothing changed.

check out! here should be walltype! @Gianni as in my screenshot

That did the job but not with the result I need.
He took every type of wall in my project and rename it like I ask in Excel. But the thing is, I don’t want to rename it, I want to change all my walls to this “21_ABS_WA_175_Kzs”. Now he just rename it but the properties/thickness/… are still the same.

Do you see a possibility to change them to the already existing type “21_ABS_WA_175_Kzs” in the project.

Thank you for the fast reply :slight_smile: !

@Gianni the thickness you can extract and than combine it f.e.

"Name" +"_" + "Value" + "_" + "Sufix" ...

But it will be still renaming the existing wall. I don’t want to touch the existing walls/floors/doors/ceilings in my project. Just want to change from 1 type, to another type. Without changing names/properties.

thats easy you can sort your walls by uniqueItem just catch the name and add the actual strength of your walltype. @Gianni

I can’t follow. See script below. What need to change?

Thanks anyway!

Excel2Revit-match_ID_2019.dyn (14.8 KB)

can you share a screenshot from your .xls @Gianni ?

See excel below, Thanks! @Draxl_Andreas
test.xlsx (17.5 KB)

Hello @Gianni ,

Try .csv… get rid of “m²”

Just use “Type” for changing the instance type to something new.

1 Like