Setting Detail Numbers

I have (had) a graph built off Nate Holland’s documented here:
It uses a parameter named VIEWPORT_DETAIL_NUMBER
It had been working fine, but now that I’ve upgraded to Dynamo 1.3, I’m getting an error in the
Element.SetParameterByName node telling me
"No parameter found by that name"
I found another parameter of the Viewport named “Detail Number”, but that one tells me it’s Read-Only.
Anyone have any idea what happened?

Does this have something to do with the addition of Built-In parameters to the Core Element nodes?

Can you post images of your graph and maybe an example viewport properties? Are you sure that parameter still exists for your viewports?

It’s a built in parameter, so yes, it exists.
Everything worked fine until I used the Element.SetParameterByName node

We need the graph or a screenshot to see where the issue is.

Here’s what I was using in 1.2

The Set Builtin Parameter node was replaced in 1.3
When I replace that node with
I get this error

Just to make sure, I didn’t do anything else wrong, I tried a different parameter and it works, except I get an error the it’s a Read-Only param
So it seems to me that Element.SetParameterByName can’t handle a built-in parameter?

Apparently, I still need the archi-lab “Set Builtin Parameter” node
I had thought that was replaced by a Core node, but evidently I was wrong.
I’d been having some other package problems between 1.2 & 1.3 and couldn’t see the archi-lab node.

As Emily Litella would say: