Set Value to Parameter within .rfa

Hello all,
This topic has popped up once or twice on this forum but to my knowledge there have been no full complete solution (I could be wrong). Simple, I want to populate a value to a parameter for multiple .rfa files without opening them. I have done this script which is running error free but when I open the family after , the parameter is not populated at all.

Any ideas where Im going wrong would be much appreciated.

10_Set Parameter value to Family.dyn (25.1 KB)

you need to save the changes made in the family, otherwise is the change only stored in the project…

I have nodes for this, check my package.

Thanks for your reply…
I want to input values into all family files only…and when complete save all families in one centralized library location. After this I will load these families into separate projects when needed.

I added the “Document .Save” node , it ran error free but again when I opened up the family after …the parameter was not populated at all.!
FYI - to run the script I just opened up a"New Project"…Could this be where Im going wrong ?


I have tried to look at your graph… I didnt see that you used my nodes in the first post, sorry for that :slight_smile:

everything looks perfect, however, I would not use a GetItemAtIndex node, since this could give you errors, write the parameterName you are trying to change. Likewise dont you need to cast the familyType to a string, I have build the node so It do this by itself.

10_Set Parameter value to Family.dyn (25.0 KB)

Hi Erfajo,
I have tested your script and it seems to work great when mapped to 1 single family in a certain location :slight_smile: Next step would be to map to multiple families in the same location (which will have the same value) … again I got an error free script, however when I went into the families after they did not populate any data into the parameter. Im thinking my problem lies within this area of the image below…Thoughts…??

Thank you

02_Set Parameter value to Multiple Families.dyn (27.7 KB)

when you use listlevel, then is the output “changed” as well. This means that you need to flatten your lists and close ONLY the first item in each sublist

by now is the “five” document you have open, the same. this one file can only be closed once…

So I think I have this working…I tested multiple families in 1 folder and each of these families had multiple types.

I did however get a Yellow warning but when I open the families afterwards they are populated correctly.

It would be great if someone else tested and get the same results for verification.

02_Set Parameter value to Multiple Families.dyn (43.3 KB)

01_Add Parameter to Family(Fully_Tested).dyn (36.4 KB)
02_Set Parameter value to Multiple Families.dyn (43.3 KB)

When you start using list level, then the output is changed. Essentially are you sending the same document several times, and you can only close a file once!
from you image to judge you should only take the first item in every sublist from the output port from the “SetValue” node.
you should verify that the number of documents you open is the same number as first item of each sublist!

1 Like

I have updated my package, this means that a new procedure must be used for Familydocument nodes…

Hello Erfan,

just want to tell you that with your Orchid package you have revolutionized the use of dynamo…

Thank you so much and I am sure that you are the first to have done such a work for the end users and firms to save them time and money.

Good luck!

1 Like

Hi Erik,
Thanks for sharing and maintaining this awesome package. Hats off for the capabilities and usability of Orchid across multiple use cases.

I probably have an issue you are able to address in a few seconds or point me in a direction of some documentation/example.

I am trying to change 15 parameters in 9 families with a total of 58 family types. How should I set up the list levels and lacing for this to work?

I think I have tried just about all possibilities using the family[1] instead of all families (shorter list just 4 indices) and I can’t get it to populate values beyond setting the same first index value to all types.

Any ideas what I could do?

Thanks in advance!
Med venlig hilsen,

For anyone facing a similar problem, here is the solution!