Set parameter values for Embedded Families

I am trying to set parameter values of an embedded generic annotation family within a Titleblock. When I use the parameter values in the Titleblock I get the error “The parameter’s storage type is not a string.” I’ve tried using String from Object but that did not help. When I use the parameter values in the Generic Annotation family I get the error “No parameter found by that name.” I am having a hard time trying to figure this one out, any help would be appreciated. Please see attached image.

Thank you!!

Dynamo%20Embedded%20Family%20Parameters%20-%20gen%20anno%20parameters|690x194

I believe the input “value” in your errored node needs to be a Generic Annotation Family, not a string.

1 Like

@Benjamin_Doty1 is correct. However, you need to figure out a way to collect the specific annotation to set it. This is easiest if you set it to shared in the generic annotation.

1 Like

Brilliant! I was able to load the Generic Annotation into my model pick the family type I needed and it works beautifully. Thank you!Solved!

2 Likes