Sending excel scripts to excel via Dynamo

I’m trying to get excel scripts into excel via dynamo, I however, do not know how. I’ve already tried it with Bumblebee package but it isn’t working for me.

Does anyone have experience with this?

This is what I currently have:

Thanks in advance!

Try to reorganise your data to be put int excel as per the below script image, then it should work.

1 Like

It should en up as repeating a list of formula’s after one another.
Would that still work for this?
And what is the difference betwen doing it like this and using a

It was just a thought for in case it was not working correctly.

Though it would be good if you could indicate the full warning that you are getting because it could be something within your text that is the issue(eg special characters)?

Also what sort of data are you getting out of the earlier nodes, eg list combine node because it may not be converting all your input data into the BB data type ready to be written to excel?

1 Like

There’s no warning and I can’t copy what’s coming out of the List.Map.

Have you checked what the output is from list combine, as the other one is to just put that into the bb data input for the write excel. No need for


That seems fine, have you tried putting the list combine node directly into the bb data slot on write excel node?

If not try this as it should work.

1 Like

It doesn’t really make a difference but the output now gives one message instead of 5.

What is the message this time and specifically what line does it say is a issue at?

Also what version of bumble bee and dynamo have you got installed?

If you have dynamo 2.0 get the latest version of bumble bee

If you have dynamo 1.3 get the next latest version down which was released in 2017

I’ve made sure that I got the right version of Bumblebee and I could still update a version that works for Dynamo 1.3.

It’s currently telling me that it can’t write to a read-only file as well as a whole lot of other stuff.
It has occasionally actually written excel but each letter of the string I send in got its own cell then.

I can’t manage to get out the entire text but here is what is a screenshot of it anyway:

Could you attached your script and i can run it my side?

1 Like

This is the entire thing so…

Luckily the important part is just:

The text in the strings is:







It seems that your long formulas are causing the issue at my side and this could possibly be a language issue between your version and mine of excel(see below image)?

Though to get over the first issue(line 96 exit error) i made sure there was a file within the given location. So eliminate the node between file path and the file path input, as it seems it can incorporate spaces without the need to add %20.

I have created the following dyn file for others peoples referencetester.dyn (12.9 KB)

I tried it with dynamo 1.3.2 and bumblebee 2017.13.2 and i get the following error

Could it be that it might work if I translate the excel code?

For your information: in the case it does do something in excel it looks like:

So it’s putting every single letter of the formula into a different cell.