Select Subassemblies by Name


First of all my name is Manuel Molina, Im a Spanish Master Civil Engenieer. I work as Maintenance Consultant. Im starting on dynamo for Civil 3D but have a bit of experience on Revit

Im trying to extract the data from Civil 3D to use them on Maintenance Software. One of the things I should take is the properties of the LaneSuperelevationAOR Subassembly and where they are applied (this is important cause I know how to take the info of the Subassmblies but not related on where they are used). I use some nodes, as can see on the image and take the hole information, but not able to filter to move from Subassembliesbystation to Parameters only with the data of the necesary subassemblies.

Thanks in advance

Hi @manumolina96,

I find that filtering is usually easiest with a List.FilterByBoolMask node. You can read how it works here:

In your case, you could get the name of each applied subassembly and then filter out the ones that do not equal LaneSuperelevationAOR, like this:


Hi @mzjensen,

Actually that is exactly what im looking for, but im having this error on my model:

Warning: Baseline.SubassembliesByStation operation failed.

And dont know what the problem could be. I have this list on Dynamo:


But on Civil 3D I have this:

Any idea on what could happen?

Thanks in advance

I upload the Civil 3d Image here as new user:

What node are you using to get the stations?


Im using this nodes:

As you see on Regions all 5 are the same as on Civil 3D, I take the startstation because they are the point of change of the subassemblies.

Can you share the DWG?

Yeah for sure

I share from weshare, it have a referenced Orthophoto that i dont share, tell me if its necessary.

I also share the Dynamo file

Hmm, this is pretty strange. I think this issue is outside of Dynamo. It looks like maybe this corridor came from InfraWorks? When I select the corridor, the ribbon does not display correctly and I get a fatal error. The Dynamo script works fine for me in a different DWG. Maybe you can experiment on some other corridors?

1 Like


I could find out the station which was causing the issue. It start station for which dynamo is unable to find subassembly by station (the error it produce for that station as Null object id) so will suggest to check corridor start station.

@mzjensen I have just audited the drawing and fixed some errors (Audit command) and it worked fine.

Edit : A simple rounding of start station resolved the issue.



Thanks to both, actually the corridor have some problems as @mzjensen said, I try to redo it and it works, but when i set multiple regions the problem comes out again.

@shahid.shaikh_C3D how should I run the Audit command to fix the drawing? I try the first option you send on Dynamo to Flatten the list and delete the first index, but if you see it only show 28 register while in the second option it shows 92.

Thank you very much to both :wink:

Hi @manumolina96,

for Audit command you can refer bellow link AUDIT (Command) | AutoCAD 2020 | Autodesk Knowledge Network.

And also for multiple regions you need to turn on the levels …please see this link to understand more about levels. Introducing List@Level: Working with Lists Made Easier - Dynamo BIM

Hope this help.


Hi @shahid.shaikh_C3D ,

Now it works, I have problem to find audit command cause in spanish its Revision… Once I use it the ribborn works again.

I also change the start station and apply the List@Levels and everything works properly now.

I can’t thank you enough

1 Like

Thanks @shahid.shaikh_C3D!

a tip for the future when using Civil 3D in other languages, add an underscore before the command to run the english command. In this case you will type _audit and should work


Thanks a lot, really appreciate the tip