Select Model Elements node problem

I was trying to test an Autodesk sample Dynamo script (Calculate Total Length of Selected Lines), and it wouldn’t let me select lines one at a time, it only works if I use a crossing window. I tried starting a new script and added a Select Model Elements node, and it is doing the same thing. Isolating the category didn’t help, and trying to select walls, doors, etc. didn’t work either. I don’t get the selection screen in Revit (the one with the ‘Finish’ button). I also tried hitting tab about a dozen times (lol), and nothing gets added to the selection. I have tried it on Manual and Automatic mode and have the same problem.

Anybody else having this issue? Any suggestions are welcome!

Thanks,
Traci

Hello,

That seems consistent with my experience using the Select Model Elements node.

An alternative may be to use the Springs Package which provides other selection methods.

Example:
image

Thanks, Robert - that worked really well! Do you know if there is a way to make that node an input? I want to be able to train users to run this script in Dynamo Player.

“Select Model Elements By Category” in the Data Shapes package will put you in a selection mode where you can click on several elements then hit the finish button when you’re happy with the selection.

1 Like

It works perfectly in Dynamo Player! Thank you Hamish!