Schedule Sorting Issue

archi-lab

#1

I am having an issue with my set parameter into a new schedule value. I havent used the function nodes before and feel it might be there. So far it has run and worked but i am missing values and most values are no in the correct row on my schedule and i cant figure out why. The “Tag Value” should be the same as the “Total Length”


ScheduleView.AddFields - How To Query Fields
#2

Hi @bharlow1986

@Konrad_K_Sobon archi-lab package node called “Schedule.SortingGrouping” will get you started.


#3

Thank you @Kulkul. I will try to implement this into my project.


#4

Im not sure if i need this node here. i have my schedule sorted correctly in my project but its getting my new output values to align also. Please see schedule above.


#5

Can you upload the REVIT file please?


#6

#7

Hi @bharlow1986,
I think your script works fine, and the problem comes from the REVIT file.
You didn’t check the “Itemize every instance” in your schedule settings. Which groups all the instances together, this will automatically ignore the Tag Value.
check this GIF: https://drive.google.com/file/d/0B4JkvehgXXfYOHoxUU9oTHJzUDA/view?usp=sharing


#8

Thanks @Ahmad_Saad. Any suggestions on how to get my two segments of length values to be calculated and tagged similar to this? This is perfect for when my lines only have a single segment but that is not always the case.


#9

Is there a way to get this node to automatically check or uncheck itemize every instance?


#10

post a feature request here: https://github.com/ksobon/archilab_Grimshaw/issues no guarantees.


#11

Hi @Kulkul
You can specify the input node “Schedule.SortingGrouping”.


#12

@griendling87_griendl

This was added to archi-lab.net package here:

image