Sat import and scale issues from revit family to revit project


I stepped over a strange problem.

I have to Sat files in mm. Checked it with the editor. I imported the sat files into a Revit Family. Now, I got two imported geometries and I can apply instance parameter for material to change it more easy in Revit later. (that is hole reason, why I do it: changing material)

I load the sat files with the dynamo player into the revit family.

The object is a tree with tree trunk and tree crown.

In the family, the tree looks nice. If I import the family into the project the trunk gets scaled to the highest point of the tree crown.
Revit Family with the correct scaled geometry.

After import the Revit Family to a Revit Project. Trunk gets scaled … :frowning:

I created also a small little object to overlap the files correctly. With that I realised the undefined scaling progress.

How can I avoid the strange behaviour or is it just an amazing bug?

Now, I wanted to know, that will happen, if I have a second marker above the highest point of the tree. I imports perfectly into the revit family. the two marker are apart by 20m. If I import the family into Revit project, the file gets scaled by the factor 4.37 …

If i’m not mistaking, planting families have a scaling option in the family template already there
You can also nest and double nest planting families
I would separatie the trunk from the foliage.

How great is that! Thank you for sharing this. I am just amazed, that I stepped randomly in to it … without knowing anything of it.

Just for history from the link:

So, with a planting family, you get a built-in “Height” parameter. This is a type parameter and it controls the “height” of the planting element. However, it does more than that. When you flex it, it will scale the entire family proportionally based on the height value. So, the tip over at Revit Swat was to simply nest in your component family into a Planting template and voila! You have a scalable family. Now it became a little convoluted as you have to “double” nest to get it to work, but the advantage of doing the double nest is you can “bury” the planting category. This is because the top level family can be whatever category you need. Just make sure that the nested families are NOT shared. This will effectively hide the planting category deep inside the nesting and allow you to drive the nested family’s size with the nested family’s planting height parameter.
So it looks like this:

Base Planting Family containing your geometry or a nested family of your geometry.

–Nest this into –

Another Planting Family (Just place an instance of the first one. This one controls the scale)

– Nest this into –

A final Family of the desired category. This family has a parameter driving the nested planting family’s Height parameter.

In the Planting family, the parameter cannot be renamed. It must be called Height. But your final family can use any name you like for the driving parameter. Furthermore, since the nested families are NOT shared, you can drive the Planting family’s type-based Height parameter with an instance parameter in the top level family if you like. Here is a simple illustration of the nesting.
Scaling_Families.rvt (2.6 MB)

1 Like

That about sums it up. :slight_smile:



1 Like