Sample case09 not working

In the official help of Civil 3d
Autodesk Dynamo for Civil 3D Sample Case09
I tried (adding an attribute with pythonScript).
However, the value of the loaded attribute is displayed as “?” In PropertyPallete. For example, Handle. Volume is also the same.
I think Japanese is the reason. Because CSV export is successful in English and not in Japanese. Also, the description of the loaded attribute was garbled. I studied myself and tried # coding: utf-8 etc but it was not good.
I want to be able to use in Japanese environment. What should I do? I contacted autodesk’s japan, but it was a response to ask questions on this forum. Thank you

What was the support case number?

ケース番号 [CaseNo:15517464.] Dynamo サンプル
されておりますDynamoコミュニティ フォーラムにお問い合わせ頂けますようお

It was the answer. Thank you.

Sorry. Is this meaning?
It is this page Case09

You gave me the right info. I needed the case number to get the insight into the history of the case and the original ask. :slight_smile:

The location of the sample file is here.
● * Dynamo Samples:
C:\ProgramData\Autodesk\C3D 2020\Dynamo\Samples\en-US
Thanking you in advance.

@GoodMotherSmiling The issue there is that those are automatic values, it happens also with Civil 3D in English, I’ll have to look into that…

Where is the Case 9 page gone?


1 Like

Not sure where the orginal page is, but since the Property Set functionalities have been made available as Dynamo nodes it was outdated. I recorded a video tutorial here

Also the Samples have been reviewed and expanded with 2020.1, the Python samples are under AutoCAD_Python_PSet_


Hi @Paolo_Emilio_Serra1

I have been trying to follow the video tutorial but I cannot get it working…

  • I have created a property data set, including the Handle parameter.
  • Then I have exported the definition to a json file using Dynamo and later on imported it to another file, also with Dynamo.
  • Then I get the problem that the Handle parameter is not recognized.
  • When I go to to the property data set definition window and I try to open my property data set (Hello Wolrd) I get a fatal error. I have tried many times, with C3D2020 and C3D2019 and every time I get the fatal error.

Any idea why I get this fatal error? Any workaround?

Thanks in advance!

As I mentioned earlier,
I really wanted to say this,
There may have been a lack of words.
Even now, only English is supported.
I tried installing English version civil3d.
The English version did the same thing and everything went well.
I tried it again in the Japanese version, but it doesn’t work.
The exported json is 0byte. Nothing has been written out.

However, I thought this was due to Japanese-specific multibyte characters.
Please respond quickly. Thank you

I am using Civil 3D in Spanish.

In my case the json file is working and I get the property data set created. It is when I try to edit the new created property data set that I get the fatal error and I cannot go on.

Could it have something to do with the language??? :astonished:

If you just want to apply to other drawings, open two drawings and copy and paste the name of the property set in the settings screen.
You may already know.
This is not the root of the problem.