"RPC server not available"- What does it mean? Please help

Hey I’m trying to use the Structural Analysis package, to create a truss geometry in Dynamo and analyse it in Robot Structural analysis. but Sometimes when I run the script I get this error message from the Packages Nods:


" RPC server is not avilable . (Exception from HRESULT: 0x800706BA) ".

Can some one explain to me what that means’ and how do I resolve this Issue. It only happens sometimes and I can’t understand way?

1 Like

This is because the connection between Robot (RSA) and Dynamo have been lost, often happens if large changes occur or you fiddle too much in RSA in between Dynamo runs.

The ONLY solution is to close both Robot, Dynamo and Revit and reload them, this will grant the connection to the RSA API a new life :slight_smile:

Also, I can recommend using the “AnalyticalBar.ByCurves” instead of the one you are showing, as it will accept both Curves and Lines, as the “ByLines” will fail for curved geometry.

It did take me a while to figure out this connection as well.

1 Like

Hey, Jonathan.
Thank you very much for answering:grinning:. It does seem to work after closing and opening all the programs.
Makes it a bit hard to debug the script, but at least now I can make some progress.

And thank’s for the pointer about “AnalyticalBar.By.Line” I’ll use it going forward.

A nice way of doing it is to get your geometry working first, and then connect all the RSA nodes to your graph.

It’s not perfect but it works 100% of the time :slight_smile:

And if a comment solved your problem please mark it as the solution anand maybe leave a like here and there :slight_smile:

2 Likes

Hey, Sorry I’m new to the forum and it’s etiquette.

1 Like