Rotate elements not working

I try to build my first script and even I have an example I can’t make it run. So the point is to select multiple elements ant rotate them by their own axis.
When I select them with pointer dynamo says nothing is selected:
when I select elements with a window dynamo considers they are selected but nothing happens (they do not rotate):
And here is the script:

The forum does not allow new users to attach files, so .dyn file is not available

Select Model Elements requires a window selection. Do you get an error with the elements selected? What kind of families are they?

1 Like

When running the script in Revit no error shows (2nd picture link above). But when building code, and especially when connecting “number” with “set rotation” a warning shows: Dereferencing a non-pointer.

Well that’s because you have nothing selected. When you have elements do you get any errors?

1 Like

When selecting from Player - no error. But when I select the column from Dynamo core ot gives that error:

I think maybe, somehow, SetRotation does not expect integer for “degree”. When I hover over it (“degree” input) I get that input suggestion-Euler angle about Z, double:

Maybe double means a number with floating point?..
The family is structural column.

Try using a code block with 45.0 as the input.

I’ve tried even the first time before posting here. Again not working.

The Select model elements is the problem you can not use it directly as input.
try as in the image.

Thank you, but I do not have a node - elements.type. I have Element types but it does not work

it is from Archilab

I know this is an old thread, but I was having issues wiht rotationg elements after placement.
The out-of-box FamilyInstance.SetRotation node does not work correctly.

I ended up using the GeniusLoci node and it worked perfectly.


1 Like