Revit crashes when loading a script with archi-lab and Clockwork nodes

We have a similar issue in our firm when testing for 2.0.X rollout where some scripts are consistently crashing Revit, some of which are mandatory for our BIM level compliance. We’re having to stick to 1.3.X for now. Hopefully 2.1 has the fix and we can move on up.

Yea I’ve been using 2.0.2 to get the upgrade hassle over with for scripts but this crash is frustrating for the others in my company who want to learn how to use Dynamo. I’ve already gotten somewhat used to not having the view extension and then using the right click search on the canvas but you have to really know what you’re searching for since the results are limited.

@Michael_Kirschner2 Can you report if this issue is still an issue in 2.0.2? My self and others at my firm have experienced the crashes similar to Steezzen. In one case a significant amount of work was lost by a user. I have instructed everyone to save before launching Dynamo. I have made sure everyone has 2.0.2 but it does not seem to help.

Can you please give an update on where the team is at in fixing this?

1 Like

Well FYI, mine crashed even when im not using any of the custom nodes for that particular script.
R19 & D2.02

It’s a known problem - yes still present in 2.0.2 - We’ve actively looked at it with multiple potential solutions - and have a current fix in the pipeline. It will be rolled out to the next fix version. We are still testing it and doing due dilligence now.


Thanks for the update. I am not sure if this is the same problem as the one with Dynamo timing out when loading large packages. I read something about it a while back.

I have found that if I start a new script first, then close it I have a better chance of the scripts that caused crashes to open. I think it may help Dynamo load less right off the bat?

1 Like

@Steven - my guess is you’ve got enough hours on the program that you might be able to get by without a library (using right click search and code blocks to work).

See if removing the file Library_ViewExtensionDefinition.xml from the path at C:\Program Files\Dynamo\Dynamo Core\2\viewExtensions keeps things stable.

This is something I’m considering myself on a semi-permanent basis. My reasoning different than stability though - I want to learn a new way to use the program at a high level, which will force me to get better at it. The more we know our tools the better we’ll be with them, and therefore the better we’ll be at our craft.

1 Like

I will give that a shot. It will make no difference to my workflow since I only right click anyway. I cannot find anything in the side menu. I only know where two things are in the springs package because I can never seem to find them by the searching. :sweat_smile:

I will report back with my finding.

1 Like

Yes that does seam to fix the problem.

1 Like

That this resolved the issue for you leads me to believe it’s the fix which Michael alluded to above. Good news is that it is in the pipeline. Bad news is that it’s not out already. In due time I guess. :slight_smile:

On my computer dynamo files that i cannot open anymore in dynamo. I stil can run dynamoplayer and then open it in dynamo. Close it and then i can open it in dynamo whithout crashing revit and dynamo.

There is a 2.0.3 dailybuild installer on the site which should include a fix for this issue. Please check it out and see if it helps if you are encountering crashes on startup or load.


thanks it solved my problems

1 Like

I made some tests on several computers. No crashes on startup/load. From my point of view it’s all good.

Thank you for the update

1 Like

I am having the same problem here, Revit and Dynamo just closes trying to openning some scripts. I tried to use this new daily build, but I failed installing it.

It’s not a .exe, should I just paste the archives over my dynamo ?
I have never used a daily build before, sorry

It should be a .exe when you download it. When I ran it it overwrote 2.0.1 with 2.0.3 and fixed all my issues.
Make sure you downloaded the correct build from the Daily Section of the builds page.

Revit & Dynamo need to be closed.


thats sandbox - use the 2.0.3 exe (not 2.3 zip)

1 Like

Well 2.0.3 kinda worked, however after restarting the issue returned.

what issue in particular are you seeing - is it similar to those in the rest of this thread? (there might be a too few mixed issues here)

Sorry, I was really trying to install the wrong thing, I found the right version and its working just fine

1 Like