Remove List From List

Hi,

I have this node, but… i dont know why… it’s not working.

Is anyone know about this?
What’s package from this node?

image

It’s from the “Rhythm” package :slight_smile:

The content is a simple line of Python

OUT = set(IN[0]) - set(IN[1])

To know why it’s not working in your setup however we’d need to know what data structure you’re feeding the node :slight_smile:

I also was thinking this… but… cant find anymore kkk

i found in another pkg…

image

image

So your issue is? Maybe show what you data looks like and how you subsequently would like it to look and a solution would be easier to give :wink:

the situation is…

Until some days ago, the note REMOVE LIST FROM ANOTHER LIST (Rhythm) was working.

Today not more.

And there is anothers nodes with the same situation…

Why is this happening? Because the owners can be refreshing the names?

Have you recently updated packages/Revit/Dynamo etc? That could cause this…

Also knowing what the error-message you’re getting from the node says would be helpful in troubleshooting the issue.

yes…

can be this…

thanks Jonathan!

by the way… about the python line…

OUT = set(IN[0]) - set(IN[1])

i started python studies 2 days ago hehe… could you tell me more about this python node?

i tried input this line and not worked

IN[0] in the python script is the first input, “IN[1]” is the second (in python index start at 0).

A “set” in Python is an unordered collection with no duplicate elements.

3 Likes

I suggest you download the next to last version of Rhythm on https://dynamopackages.com/
You will find the node in the zip.

Drop the RemoveListFromList.dyf in the folder C:\Users\XXX\AppData\Roaming\Dynamo\Dynamo Revit\VERSION\definitions

3 Likes

Thanks guys…

@Jonathan.Olesen , i will try python!

@Alban_de_Chasteigner… it worked… but, the strange think is that i have did the package refresh before… but just worked after download

image

I noticed that the node is no longer in the latest version (2018.6.7).
It is in version 2018.4.20.

@Jonathan.Olesen’s answer is a good opportunity to practice the python language.

oh yes!!

i clicked in a wrong link… and got the node kkk

that’s ok!

thanks

@daniel.petrin If your objective is similar to the graph provided by @Jonathan.Olesen above, you can do this …

3 Likes