Rebar Tag Location Not Working As Expected

Hi All,

I’m dealing with an issue I don’t know how to fix. I have a script that puts the rebar tags in a defined location. If I run my script the first time I get the rebar tags created but not in the location that I wanted.

But, if I run it the second time, it moves the rebar tags to the desired location.

Python N°1 Just re-arrange the data structure but in Python N°2 I put some parameters for the location of the tags.

The model is in Centimeters.

Really don’t know what can it be.

Thanks in advance.

Script: Rebar Tag Location.dyn (220.6 KB)

This is the model used:

well i have a problem with the parametername “Family and Type”…Dynamo can’t find the parameter

my fault…the parameterName is in german a little bit different…

But when i restart dynamo the tags diden’t move…
here is my result:

HI @Fiesta.

¿What do you mean? If I run my script once, but not closing Dynamo (so the instance is still open) and I run for second time, I get the desired location.

If I run it once, close Dynamo and open it, I run it again I get the same result as the first time. The wrong location.

Can you try not closing Dynamo please?

Thanks in advance!

I have now the same behavior like you.
The position of the tags is changing to the desired location after i run the script the second time.
Sorry…in the moment, i can’t explain why…

Thanks! At least it’s not just happening to me! Thanks a lot for your time :slight_smile:

Hi all. Just reviving this thread.


It is advisable to get the view plane and get a geometry by intersection with the host element or the rebar to obtain points on those geometry. Those point at any point will be within the view.