Tag element not working


Hello, I am trying to tag a bunch of items after I place them with dynamo, however all of the tags are ending up in the same spot. And this only seems to happen after the first time i run this. The first time I run it its comes in ok, then I try to change the length of the vector to get alll of the tags off of the elements and then it does this? What is going on here and do I need to restart revit/dynamo everytime? How can I fix this issue? Also I dont understand what this warning means. Please advise. thanks.


can you share your definition? and perhaps tidy it up a little before that? :wink:


AutoPopulate1.dyn (331.5 KB)
Sure no problem!


Can anyone point me in the right direction on this please? Thanks!


@mix Putting a Transaction.End node after the created Family Instances places the tags offset correctly from the elements. If you put an Element.Location node after the FamilyInstance.ByPointAndLevel node you will notice that they all report the same (incorrect) location point, unless the transaction is ended first.

I cleaned up your graph and organized them into groups for you (groups are very useful for your own use but its also good practice for when uploading files here so its easier for others to help figure out what’s going on) :slight_smile:

AutoPopulate_mix.dyn (82.9 KB)

Let me know that this works for you - it ran properly on my end, but as a slightly modified version (because I didn’t include the set parameters portion when troubleshooting) on Dynamo 1.3.2 and Revit 2018.