Rebar.byCurve weird bug (?)

revit
dynamoforrebar
dynamo
vector

#1

Hello guys,

When using Dynamoforrebar’s Rebar.by.curve node I am experiencing a rather interesting bug. Whenever I run the program it gives me back an error in the node mentioned, saying that the host is not valid. However if I change anything in the parameters, as little as it can be, and run the program again the error disappears and I get to see my rebars on REVIT. Currently I keep changing the boolean value on the vector node in order to make the rebar.by.curve run, making me believe the problem is actually not with the host.

1º Run:

2º Run (changing the boolean)

Result:

So far I’ve also change the value of the vector to 2 (instead of 1) and it also worked in order to make the program run. Even though I can make the program run (on the second try), I would like if someone knows a way to run my program on the first try.

Thank you so much, in advance.


Rebar.bycurve / Element ID listed
#2

Hi @MargaridaMB

Could you show your complete graph with previews on for all nodes.


#3

Yes, of course, I’m working on it. I’ll post a print in a minute. Thanks for your help.

Update: Here are the prints, thank you for your patience.

1º Run:

2º Run:


#4

Try adding Transaction.Start after host id and Transaction.End after Rebar.ByCurve node.


#5

Thanks for the reply, but sadly it didn’t work.

1º Run:

2º Run (Changing the boolean in vector):


#6

Should I try and modify the way I convert the line to a curve?


#7

Solved, added transaction start and end, before and after element.id,

@Kulkul Thank you for all your help :slight_smile: