Rebar.bycurve / Element ID listed

revit
excel
dynamo

#1

Hello guys,

I have previously posted about a problem I was having generating rebar on the first try. Basically the program only generated the program on the second time i clicked run.

Here is the link of the topic:

I investigated and simplified the program to find out what was happening that was making the node bug (Rebar.bycurve). So I came to the conclusion that maybe it’s because the structural floor that I automatically created through EXCEL came with its ID listed at the 0 index.

However if I pick the same element through select model element and link it to the element ID node it comes out as only a “number”(?), and the node rebar.bycurve runs normally and generates my rebar correctly.

My question is, do you think this observation is reasonable, and if it is, is there a way to convert the list into a single element ID number?

I wanna apologize for my inexperience and ignorance in DYNAMO, I am in fact a newbie, but I really do need help.

Thank you in advance.


#2

Hi,

can you try Flatten Node After Element.Id and before Rebar.ByCurve.


#3

Thank you for your suggestion @robert12546358, but, unfortunately it didn’t work.

This is the simplified dynamo routine:


#4

Please share a .JPEG file not .PNG file


#5

There you go:


#6

I think you can change curve.(see image)


#7

Also, didn’t work :sweat: (thanks :smiley:)


#8

I guess the rebar.bycurve doesn’t work with list, since both the Element ID and the curve are in list form and the other parameters are not. So is there a way take the element ID and the curve out of LIST form?


#9

Can you please share your .rvt & .dyn files??


#10

i can, i’ll just simplify it a little bit. Give me a minute and thank you.


#11

Here is the dynamo and excel file: (the rvt file is too big, even tho it’s just a blank one, I can’t upload it)

teste.dyn (39.3 KB)
test.xlsx (8.1 KB)


#12

i have some changes in nodes.

Final_teste.dyn (44.9 KB)


#13

It isn’t working either with the changes when I tested it out. :S


#14

Please check all Rebar details


#15

remove flatten Node before Rebar.ByCurve.


#16

Still not working :confounded::fearful:


#17

I also attached Image.


#18

you’re really sweet for trying to help me out, but I don’t know why yours is working and mine is not. maybe it’s because your version of dynamo is not the same as mine?


#19

Solved, added transaction start and end, before and after element.id

@robert12546358 Thank you for all your help :slight_smile: