Reading Superstruture Parameter with SOFiSTiK Bridge + Infrastructure Modeler nodes


I am working on a dynamo script that reads parameters from an axis and superstructure of a bridge created with SOFiSTiK Bridge + Infrastructure Modeler. I am working with Revit 2023 and the new SOFiSTiK Bridge + Infrastructure Modeler nodes provided by SOFiSTiK. The script works as far as I get the required parameter names and values.
Unfortunately, the parameter values I get in the script are not the same values I entered during modelling.

Does anyone have any idea why the values differ?

As I am a new user, I cannot upload any files.

Hi! @sbormuth

Maybe it is a units problem. Try to convert data with Dynamo’s convert units node.

Look also:

Without an screenshot or detailed explanation it is hard to understand what is actually happening. What exactly are you trying to reed and why the values are not correct ?
It sounds like a problem with units but on my side it looks well (see pics).

Thank you for your replies.
I will invasitgate the units and update if that was the problem.
Until then here are screenshots of the script. With the axis I get the same result as @msl but with the superstructure the results are incorrect.

Converting the units worked.

Again thank you for your input!

@sbormuth You are rigth, the Units for ComponentParameters are only working correctly when you assign an Expression or a reference to an Axis, but they are currently wrong in case of constant values. It should be fixed for next release.

1 Like