Read Excel and set parameters, Make it easy :)

Good morning,

I’m using an excel file to populate a parameter in Revit. It is working fine but I suppose that I can make it shorter because I need to apply this to all my pipes.ReadExcel_AdParameter.dyn (136.8 KB)

(It is about the last part in blue)P009283 Structure CDC - 180509.xlsx (60.8 KB)

Zoom in on your graph and use the camera option in the right corner. This way it is possible to actually zoom in on your picture which will make it easier to help you. :slight_smile:

(I know you’ve uploaded your .dyn, but sometimes the obvious solutions are easier to give without having to start dynamo or close the project you’re currently working on.

I think you will be glad with my printscreens :slight_smile:

Ouch … is it not so easy to make it simple :frowning:

Have not yet had a chance to try, but it seems that you should just load it all in and start sorting afterwards, an alternative would be to make custom nodes as you’re repeating a lot of nodes. Will get back when I have a spare moment…

I would need your .rvt file. Also you need to specify if the nodes are not from core package, this is why they are marked “unresolved”.

Have you tried this instead of your jumble?

1 Like

thank you sir :slight_smile:

With this proposition of you … how can I know that the right data (from excel) are in the right (ø) parameter?

yeah those not standard nodes … When I use them then I write from which Package they comes, this one is from ‘ExcelReader’

I don’t understand your question?

You control the “data” by your “range” option on the excel reader…

You have already sorted your elements thus:

But I don’t know how you’ve decided to sort your data, that is up to you…
But it seems like you are assigning sizes very much manually and the sizes do not match your excel sheet, thus will they mostly be random if your topography change or you add a pipe…

Ho my goodness!!! your proposal is really really easy! I just made it to complicate.
But because I already sort my ø in Dynamo and it match my excell, I just have to link it has you said
I test it and it works perfectly!

in my Revit file I have indeed now pipes from ø16 until ø160 but not in my excell … but this is a test and will change that!

Super man! I presentation for tomorrow will be better now :slight_smile:

I’m glad that it worked, couldn’t understand why it shouldn’t work :stuck_out_tongue: I’m glad I could help, sometimes all you need is a fresh pair of eyes.

your eyes made my day :joy: