Python and Code Block nodes not working

I have recently installed Dynamo 1.2 and am using Revit 2017. The Python Script node does not seem load properly. I did not have this problem with v1.1 when running Revit 2016 or 2017. Additionally, I cannot edit Code Blocks when placed while using 2017, they work fine in 2016. Any thoughts??

I can place Code Blocks but not edit them…

Thanks for the help

Ben

Hi @Benjamin_Doty1

I suggest you uninstall completely your dynamo including delete all files from C:\Users\you name\AppData\Roaming\Dynamo and install latest dynamo version from here http://dynamobim.org/download/

@Kulkul thanks for the suggestion. I have uninstalled completely and the Code Block now works properly, but still no luck with Python Script node.

I have done uninstall and reinstall 3x and am now thinking this has to do with the Windows 10 update that was pushed to my workstation over the weekend. I will set this topic as resolved as this appears to be my own issue.

I’m having the same issue. I’ve uninstalled and deleted the Dynamo folder but the Code Block still doesn’t work… and I’m not on Windows 10 (just 7 here). Any other thoughts?

Hello, this could be the answer:

Should have posted the answer earlier, or at least my answer. Iron Python 2.7.0.40 could not load or be recognized, not sure which one. I went through and uninstalled it and let Dynamo install Python and everything work fine from their on out.

1 Like