Dead Code Block Nodes in D4R

codeblock
revit

#1

When using Dynamo for Revit if you experience Code Block Nodes that you can not edit the root cause may be a collision with another instance of the AvalonEdit Open Source component: ICSharpCode.AvalonEdit.dll, found in the Dynamo Core folder under Program Files and also under the Revit SDA folder. Revit Addins may pull in their own version of the dll as well, for example DisplayBindings.

A suggested workaround is to simply rename the Dynamo version of the dll so that Dynamo is forced to use the other installed one. We do not know of any adverse effects to using this workaround until we fully solve the issue.


Python and Code Block nodes not working
Code block and python script
Code Block not working - Python code crash
2.0 broke my 1.3.2
pinned #2

#3

Hmm, this fix didn’t seem to do it for me. Filed here https://github.com/DynamoDS/DynamoRevit/issues/1432


#4

This update fixed this issue for me!


#5

That’s the build I’m on and I’m still having problems with this. I’ll try reinstalling the update.

edit - working now - I suspect a recent reinstall of Dynamo reinstalled that DLL - killing it fixed it for me


Codeblocks paradox
#6

I also faced the same problem in Dynamo v1.2.3. I had to go back to the previous version.


#7

Worked like a charm. Thanks.