Problems Writing to Excel


#1

I have looked through several posts (including the read from excel posts) and think I have all the nodes correct, but still no luck. I am using Revit2015, Dynamo 0.7.5 and Excel 2013. I first tried to write to an existing document on our network. Then I tried a new file on the network. Last tried a new file on my desktop. Excel does open, but no data is written to the file. Is it possible it is some security setting in Excel preventing the write? It just doesn’t seem that difficult!

2015-02-12_0953


#2

s2015-02-12_08h50_32 try flattening your list to see if that helps.


#3

I thought the same thing John, but no luck. Of course, the flatten wouldn’t give me the result I wanted, but I was hoping just to see something written to excel. May just try a totally new Revit file and simple data.

2015-02-12_1101


#4

Thanks to Ben Osborne for helping me work this out. He asked if it was possible I was sending null information to Excel…which I thought might be a possibility because of the following errors, I had ignored because the resulting data looked right to me…

2015-02-12_1154

 

2015-02-12_1155

 

 

 

 

2015-02-12_1157

 

Ben suggested using List.Map and String from Object, which resulted in the data being written to Excel!

Thanks Ben!


#5

John, I apologize…in re-reading the post, I realized I had put the Flatten node in the wrong place, but I tried it and it still didn’t work.