Problems Writing to Excel - ExportExcel List length cut-off


#1

Good day everyone.

I’m having issues using the ExportExcel node to write to a predefined Excel Spreadsheet. The function runs, but with warnings every time I run it. The real issue is that it cuts off the list at around 650 line entries, and the list to export contains approx. 12500 entries.

Warning it lists is: “Warning: Data.ExportExcel operation failed. Exception from HRESULT: 0x800A03EC”

Tried using the BB Data and WriteExcel nodes from the archilab_Bumblebee package but that doesn’t do anything.

Exporting to .CSV works fine, just not as user friendly. Any ideas?

TextNotes_Extract.dyn (40.2 KB)


#2

A simple search (right top) gives me


#3

Apologies, I didn’t come across this when I searched - I obviously used the wrong search criteria.

The proposed solution to that thread doesn’t address, or fix my issue as neither of the suggested answers are applicable.


#4

What was the result you got with the bumblebee nodes?


#5

“Warning: Data.ExportExcel operation failed. Exception from HRESULT: 0x800A03EC”

It managed to write 648 lines to the Excel Spreadsheet, but nothing thereafter.


#6

What version of excel are you using? Include if it’s 32 or 64 bit. Also, what OS, Revit build, and Dynamo build. May help to have your Dynamo logs on this as well.


#7

System Stats:
Microsoft Office Professional Plus 2010 - 32bit, version 14.0.7015.1000
Windows 7 Enterprise 64bit with Service Pack 1 installed
Revit 2018 64bit build 18.3.1.2
Dynamo Core 2.0.1.5055
Dynamo Revit 2.0.1.5065

Log attached as .txt fileLog.txt (23.1 KB)


#8

May be that excel 2010 isn’t supported due to a break API change by Microsoft. I’ll look into it on this end, but see if you can get an updated version on a machine to test with.


#9

I’m tied into a corporate license for Office unfortunately.

There is an OOTB node for exporting to Google Sheets I found last night that I am going to try with the script. I’ll post the result here.


#10

Hi @chrisrossinnes

Do these changes and it will work for you:

  • Remove all custom packages and install only clockwork package.
  • Remove Whitespaces from strings, add String.TrimWhitespace node after TextElement.Text node.

Cheers!


#11

Thanks Kulkul! That worked perfectly, and made the script leaner too.

Posting fixed .dyn here for reference.

TextNotes_Extract.dyn (29.3 KB)