Why does this happen?
How should it be solved?

Hi @Dongzi,

Why don’t to try to add an element to your node IN[0]?

import clr

import RevitServices
from RevitServices.Persistence import DocumentManager
from RevitServices.Transactions import TransactionManager
doc =  DocumentManager.Instance.CurrentDBDocument

import Revit

from Autodesk.Revit.DB import *

elems = UnwrapElement(IN[0])



OUT = elems

hi,It can be achieved with IronPython, but with Cpython it still doesn’t report an error, showing “NameErrer”.

@Dongzi it is working from my side with CPython3; Can you share your DYN file?

Question.dyn (3.2 KB)
hi, there is only PythonScript here, but it still reports an error, can you see why?

@Dongzi I downloaded the dyn file. didn’t give any error.

@Dongzi your file is working from my side as well, I think you need to install Python 3. on your machine.

I installed Python 3.8.3, and everything else runs normally. Excuse me, is your Dynamo version up to date? Revit2022 version used?

I am using Revit 2022 Dynamo 2.12.0

I am using Revit2021, and then upgraded Dynamo to 2.10, will it be the reason for my upgrade.I’m using the cracked version. . The original is too expensive. . . .

hello @Dongzi
any reference to cracked software versions is prohibited on this forum.
CPython3 engine is not available before Revit 2022, this topic will be closed
if you are a student, try to apply for an educational license of Revit :slight_smile: