Populate Multiple Key Schedules With Excel Data

I’ve only been using Dynamo for a few weeks so forgive me if I say something silly below, but I’ve been stuck on the same problem for way too long.

I’m attempting to create, and populate several “Equipment note” key schedules from an Excel file. I’m trying to do so by using the “Key Schedule” node from the Archi-lab_Grimshaw package and I can’t seem to get it to work for multiple schedules at once. I’m using Revit 2016 and Dynamo 1.3

So far, I have been successful with the following:
• Creating new, empty, single column, key schedules (the single column being the “Key Name” column)
• Manually adding additional columns (IE project parameters) in Revit. From my understanding, project parameters cannot be created with Dynamo. (Hopefully I’m wrong about this. If so, please advise)
• Adding my desired data to a single, prebuilt key schedule with Dynamo. For example, the following nodes populate the key schedule below. This is exactly what I want, I just want to be able to do it for multiple schedules at once.

However, when I try to perform the same task with multiple schedules, I just get a “null” output and the schedules are not impacted at all. I don’t get any warning from the node. See snip below for the structure of the inputs.

In the case above, I have the following inputs:

ViewSchedule: A list of 6 schedules I’m trying to populate. This list comes from the ScheduleView.CreateSchedule node. It doesn’t appear that re-running the script re-creates these schedules if they already exist (at least my added parameters are not deleted).

Data: 6 lists corresponding to the 6 schedules. Each list contains a sub-list of the values I want to populate.

Parameter Names: I have manually added each of the parameters to all 6 schedules and made sure each is a text parameter.

Any thoughts as to what I’m doing wrong?

I have also tried the following list.map set up without success as well. It doesn’t appear that this set up has any impact on the schedules.

1 Like

It looks like your lists match up so you should just need to fix your lacing. Right click your Key Schedule node and set Lacing to Longest.

EDIT: Looks like I misspoke. Your Parameter Names list doesn’t match your Data list. You need to group your parameter names by ViewSchedule as well, one for each item in Data.

Changing the lacing to longest seemed to do the trick (at least initially)! I’ll need to do some testing with different data sets to make sure. Thanks! Don’t know why I didn’t try that earlier.

I also don’t think it’s going to let you set different parameters for different keys. I think you’ll have to set all the parameters for each key but leave some of the values as blanks (""), if that makes sense…

I might be misunderstanding, but I don’t think Revit will allow me to have same parameter for more than one key schedule. Because of the way key schedules work, I believe allowing the same parameter to be associated with different keys could lead to conflicting parameter values.