Polycurves muy be branching error

Hi all!,
I’m new in dynamo, trying to draw a polygon by some points. When I try to draw the polygon, I receive the next error

Dynamo routine


Dynamo error:
img1
Unfortunately, I was not lucky trying to find the same issue

Thank you in advance for helping me!

Hi,

I did a quick search on the forum and this came up?

https://forums.autodesk.com/t5/revit-api-forum/how-do-i-get-and-set-the-view-design-option-override/m-p/5209907/highlight/false#M6995

Perhaps you can work through this and other posts and see if you find a solution?

Be sure to post your efforts so people can help fix them :slight_smile:

Good luck,

Mark

Sorry Mark, I cant see any relationship between your post and my question. Dis you undrestood my question?

Sorry, doing it on a phone, here’s the correct link…

I searched on the forum for ‘Polycurves May Be Branching’.

1 Like

Could be related to the order of the points being sent.

Try dropping the last half of the points and see if that fixes it. If not, drop the first half; if it fixed it try dropping the last quarter.

That will allow you to more quickly zone in on the problematic point(s).

Double checking your working range may also help. Are the units in feet? Meters? Inches? How many decimal places do you need? If this is a working range issue the geometry will usually ‘jump’ or ‘dance’ when you navigate the 3D preview.

1 Like

Finally I solved it taking only representative points on the same plane to create the surface. Topographic survey gave information that i had to filter.
Thank you all!

2 Likes