Points from Excel List

Hi, I have created a list of points in excel and brought them into dynamo and am trying to create a series of points from them. I have gotten them chopped up into three lists of x coordinates, y coordinates, and z coordinates. However, I can not figure out how to convert these lists into points. I tried to use them as the inputs to a point by coordinate node but that did not work. I need dynamo to somehow recognize them as coordinates. I am very new to dynamo so sorry if this is something simple.

Please post an image. is it possible that dynamo is recognizing your points as “Text” and you need to convert the strings to numbers using “String To Number”

Should work…

1 Like

You will find a few other posts on a similar topic- such as http://dynamobim.org/forums/topic/huge-tree-table-in-excel-how-can-i-get-this-into-revit/

Vikram (aka ‘Lord of the Lists’) transpose & code block nodes are a more elegant way of splitting up the data columns than the example in that post




This might be a “very old” post but I was wondering why when I try exactly the same script I don’t get a list of points after Point.ByCoordinates… Any help, please? Is it because Dynamo changed?

I have a table with 4 columns in Excel. The first, I would like to become annotations in C3D and the others are X,Y and Z.

I would like to import them from Excel and place them in C3D.

Vary basic, but I am crawling in Dynamo…

Many thank sin advance for any help!

PS1: I am tagging you @Vikram_Subbaiah because you seem to know what to do. Apologies for disturbing…

PS2: @Andrew_Hannell, the link does not exist… (Error 404 - Page not found / Oops! That page can’t be found.)

the forum was upgraded (or migrated to a new platform?) ages ago & old post were transferred across
I thought the old links still worked but maybe not.

If you search you will find the post, with a different URL
Huge tree table in Excel, how can I get this into Revit - Packages - Dynamo (dynamobim.com)

Refer to the second to last post from me- someone else had the same problem with attachments dropping off

Do you get the exact same list structure until then?
You’ll need to share your files/screenshots for us to provide a solution to your problem.

Thank you, @Vikram_Subbaiah!

There you go:

Block not available:

Replaced by:


The only way out for me was to use COGO Points - which leads to other problems so not really a solution…

Many thanks again!


Strangely, this “change” worked today, although I cannot see the points in C3D’s Model Space yet.

Dynamo Test - Import Points from Excel - Vikram’s version.dyn (18.7 KB)

1 Like